Aimless

CiscoとYAMAHAで、IPIPトンネル&OSPFしてみた。

network

とある方とIPIPトンネルを掘ってOSPF over IPSecをやろうと頑張っておりますが、上手くいかなかったので自宅で検証しています。自宅の検証環境はこんな感じです。OCNのPPPoEとGMO固定IPがあるので、疑似的にグローバルIP間でのトンネル堀り検証が出来ます。

nwdiag oof IPIP tunnel

LANだと上手くいくのに・・・

 グローバルIP同士だと上手くトンネルが掘れなかったので、まずは192.168.2.0/24のLANセグメントでIPIPトンネルを掘ってみました。下記設定で互いのトンネルIPアドレスに対してPingが飛ぶので上手くいっていると思います。

■Cisco Configuration
interface Tunnel10                                                              
 description test-ipip                                                          
 ip address 172.16.16.1 255.255.255.252                                         
 tunnel source 192.168.2.254                                                    
 tunnel mode ipip                                                               
 tunnel destination 192.168.2.200 
■YAMAHA Configuration
tunnel select 10                                                                
 description tunnel test-ipip                                                   
 tunnel encapsulation ipip                                                      
 tunnel endpoint address 192.168.2.200 192.168.2.254                            
 ip tunnel address 172.16.16.2/30                                               
 tunnel enable 10

さらにOSPF

 開通したIPIPトンネルでOSPFを回します。なぜだか不明ですが、RTX側のIPIPトンネルに対して明示的にRemoteAddressを追加しないとOSPFのネイバーが上がりません。

■Cisco Configuration
router ospf 1
 router-id 36.2.107.xxx
 redistribute connected subnets
 redistribute static subnets
 network 172.16.16.0 0.0.0.3 area 0.0.0.0
■YAMAHA Configuration
tunnel select 10
 description tunnel test-ipip
 tunnel encapsulation ipip
 tunnel endpoint address 192.168.2.200 192.168.2.254
 ip tunnel address 172.16.16.2/30
 ip tunnel remote address 172.16.16.1
 ip tunnel ospf area backbone
 tunnel enable 10

ospf use on
ospf router id 192.168.2.200
ospf log interface neighbor packet
ospf area backbone
■Cisco Result
Router#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.2.200     0   FULL/  -        00:00:39    172.16.16.2     Tunnel10
■YAMAHA Result
# show status ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         
36.2.107.75       1   FULL/  -        00:00:36    172.16.16.1     TUNNEL[10]

グローバルだと全然だめ・・・

 いけそうな設定が確認できたの同様の設定をグローバルIPでやってみたのですが、全く上手くいきません。何よりもIPIPトンネルが開通しません(互いのトンネルIPにPingが飛ばない)・・・。なんとなーくRTX側のNAT Descriptorが怪しそうなので引き続き検証します。

29 Jan 2012